Compathy - Travel Collections around the world beta ver.

System Requirements

Compathy recommends using a browser that supports HTML5.

Our recommended HTML5 compatible browsers are listed below. Please be aware that some features may not function properly if you are not using one of the following browsers.

  • Google Chrome(The newest Version)
  • Safari(The newest Version)

FAQ(Frequently Asked Questions)

I can't edit logbooks properly from smartphones and tablets.

Our apologies for any inconvenience you may experience. We are currently working on the functionality required to allow users to properly edit their logbooks.

I can't upload pictures from Android devices.

Depending on the model of your Android device, the picture upload function may not work when using the default Android browser.
Please use the latest version of Chrome Chrome for Android.

Back to TOP